Tp-link tl-wr841nd

Режим повторителя

Режима повторителя в обычном понимании у роутера нет. Разработчики пошли несколько другим путём. Включая повторитель, обычный маршрутизатор отключает домашнюю беспроводную сеть.

В режиме репитера Tp-Link Tl Wr841n может, не прекращая работы домашней сети, усиливать ещё одну. Для этого служит функция WDS, о которой говорилось разделом выше.

Установка галочки в том пункте выдаст такое окно.

Здесь:

  • «SSID» — имя точки доступа, к которой нужно соединиться.
  • «BSSID» — дополнительная зашита, адрес точки доступа. Так как подразумевается МАС-адрес, лучше воспользоваться его поиском, нажав на кнопку ниже.
  • «Тип ключа» — метод шифрования, который применяется в сети подключения. Рекомендуется, чтобы домашняя сеть использовала идентичный метод, что позволит избежать проблем подключения в будущем.
  • «Индекс WEP» — в каком виде вводится пароль, (ASCII) (нормальный буквенно-цифровой) или HEX (шестнадцатеричный).
  • «Тип аутентификации» — должно совпадать с предыдущим параметром.
  • «Пароль» (сети подключения).

Введя все данные, окно закрывают.

To Upgrade

IMPORTANT: To prevent upgrade failures, please read the following before proceeding with the upgrade process

  • Please upgrade firmware from the local TP-Link official website of the purchase location for your TP-Link device, otherwise it will be against the warranty. Please click here to change site if necessary.
  • Please verify the hardware version of your device for the firmware version. Wrong firmware upgrade may damage your device and void the warranty. (Normally V1.x=V1)How to find the hardware version on a TP-Link device?
  • Do NOT turn off the power during the upgrade process, as it may cause permanent damage to the product.
  • To avoid wireless disconnect issue during firmware upgrade process, it’s recommended to upload firmware with wired connection unless there is no LAN/Ethernet port on your TP-Link device.
  • It’s recommended that users stop all Internet applications on the computer, or simply disconnect Internet line from the device before the upgrade.
  • Use decompression software such as WinZIP or WinRAR to extract the file you download before the upgrade.
TL-WR841N(EU)_V14_200903
Published Date: 2020-11-27 Language: English File Size: 4.27 MB

Modifications and Bug Fixes:
1. Enhanced safety
2. Added the Led Control function
3. Added the WAN Link Status function
4. Optimized the wireless function
5. Optimized user experience of configuring the router

TL-WR841N(EU)_V14_180319
Published Date: 2018-04-03 Language: English File Size: 4.23 MB

Modifications and Bug Fixes:
1. Optimize the LED display in repeater mode.
2, Fix the bug that LAN_IP would not redirect when in the same subnet with WAN in PPPoE/L2TP/PPTP mode.

Notes:
For TL-WR841 EU v14

Hardware

Version v3 v5 v7 v8 v9 v10 v11 v12 v13 v14
Instruction set: MIPS
Vendor: Atheros MediaTek
bootloader: uboot
System-On-Chip: AR9130 AR7240 rev 2 AR7241-AH1A AR9341 QCA9533-AL3A QCA9533-BL3A QCA9533-AL3A MT7628NN
cpu Frq: 400 MHz 535 MHz 550 MHz 650 MHz 575 MHz
BogoMIPS: 265.42 265.42 265.42 266.64 366.18 432.53 385.84 385.84
Flash-Chip: ST 25P32V6P Hynix Eon EN25F32-100HIP Spansion FL032PIF Winbond 25Q32FVS1G Spansion FL032PIF GigaDevice 25Q64CSIG GigaDevice 25Q32CSIG
Flash size: 4 MiB 8 MiB 4 MiB
RAM-Chip: Hynix HY5DU561622FTP-5 Zentel A3S56D40ETP-G5 ESMT M13S2561616A-5T Winbond W9425G6JH-5 Zentel A3S56D40GTP-50 Zentel A3S56D40GTP-50L ESMT M14D5121632A -2.5B / Winbond W9751G6KB-25 Zentel A3S56D40GTP-50L
RAM size: 32 MiB 64 MiB 32 MiB
Wireless: Atheros AR9100 Rev:7 Atheros AR9280 Rev:2 Atheros AR9287-BL1A 2.4GHz 802.11bgn AR9341 QCA9533-AL3A QCA9533-BL3A QCA9533-AL3A MT7628NN
switch: Marvell 88E6060 AR7240 built-in AR7241 built-in AR9341 built-in QCA9533-AL3A built-in QCA9533-BL3A built-in MT7628NN built-in
USB: No No No
Serial: Yes
JTAG: Yes No

Wifi Выдает только 130МБит/c?

Изменение данной настройки в домах с большой плотностью wifi точек, может только ухудшить производительность вашего роутера вечером, когда соседские точки сильно загружены.

Суть в том, что по умолчанию в Openwrt соблюдаются законодательства разных стран и при присутствии других wifi роутеров, ваш роутер сбрасывает канал 40mhz до 20 mhz, дабы не загрязнять эфир и не ухудшать собственную производительность, хотя сообщает что умеет 300МБит/c и 40mhz, а так как у нас режим MIMO 2:2, то при 20mhz получаем 130 МБит/с по стандарту.

Как исправить:

Заходим по ssh(если вы еще не установили пароль, то по telnet) и вводим команды:

uci set wireless.radio0.htmode=HT40 /выставляем ширину канала 40mhz, можно и через веб интерфейс.
uci set wireless.radio0.noscan=1 /запрещаем роутеру сканировать окружение.
uci commit wireless /записываем наши команды в конфигурационный файл.
wifi /перезагружает wifi интерфейс с новыми настройками без перезагрузки роутера.

И получаем честные 300МБит/c

Редактируем файл

  1. Под config wifi-device ‘radio0’ добавляем

    option noscan '1'
  2. option ‘htmode’ выставляем значение HT40 (для билдов до BARRIER BREAKER(14.07) значение принимает HT40+ или HT40-)

    option htmode 'HT40'
  3. Перезагружаем wifi

    wifi

Basic configuration

With BARRIER BREAKER (Bleeding Edge, r40867)

Tested with the wr841n v9 with or better . The system supports multiple virtual access points.

Modify the files that follows according to your needs (and, in the case, search for the file definition here in the wiki to understand how it works)

etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  9 #same channel of the existing wifi network
        option path     'platform/qca953x_wmac'
        option txpower  12 #this depends on your needs, default is 20 dBm. Lower it is healthier (citation needed)
        # REMOVE THIS LINE TO ENABLE WIFI:
        #option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     'This_is_a_new_wifi_network'
        option encryption       psk2 #wpa2 psk
        option key      'this_is_the_wifi_password'

config wifi-iface
        option device   radio0
        option network  wan
        option mode     'sta'
        option ssid     'This_is_the_name_of_the_existing_wifi_network'
        option encryption       psk2
        option key      'this_is_the_wifi_password_to_get_the_connection'
etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'here is written something, no need to modify it'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.11.1' ä modify this according to you needsfor the lan network
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        #option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
etc/config/dhcp

Pratically unchanged

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wan6'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'
        option master '1'
etc/config/firewall

Pratically unchanged because the “client” wifi is connected to the “wan” interface, while the “repeater” wifi is connected to the lan interface, thus the firewall is basically already configured.

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan
Final actions

Just be sure that the files are saved. To edit the files on windows, either use vi on the openwrt, check for a tutorial online, the basic commands are not difficult; or use winscp with a SCP connection and edit the files with an editor on windows. Then reboot the system and check for the wifi connection.

Remember that if the “client” wifi doesn’t work, won’t work also the repeater wifi network.

attitude_adjustment 12.09 (final)

The default wireless configuration is different, for example
there is no: ‘ .
Further investigation shown that the wireless is able to provide an AP
if connected to whatever interface defined in ,
while for ‘sta’ mode (a wifi client) it is possible to obtain it only if
the interface connected to the wireless configuration is not using the option nor having a relation to a switch with more than one port (for example if with eth0 we define a switch over multiple ports) Note: would be better to check this statement more thoroughly.

For example, with the configuration reported above for barrier breaker, the wlan is linked with the wan side, that is using no switch interfaces nor bridge protocol. This works too for 12.09.

Go back to original firmware

→ generic.uninstall

Warning!

This section describes actions that might damage your device or firmware. Proceed with care!

With the TL-WR841ND router, there is a catch: the stock firmware is obtained from the OEM: versions 1,5,7,8,9(versions v1 and v1.5 have same latest fw) and link for v3

  • in case the file name of this firmware file does not contain the word “boot” in it, you can simply revert back to original firmware
  • in case the file name of this firmware file does contain the word “boot” in it, you need to cut off parts of the image file before flashing it:

The following method applies for the V1, V3, V5, V7, V8, V9, V10 and V13 since the bootloader is the same size.

An example of an image file with the word “boot” in it is .

Cut the first 0x20200 (that is 131,584 = 257*512) Bytes from original firmware:

dd if=orig.bin of=tplink.bin skip=257 bs=512

You should transfer the firmware image to the /tmp folder and revert back to original firmware (if available you can flash the firmware via the webinterface as well):

Via the safer method using sysupgrade:

sysupgrade /tmp/tplink.bin

Or you use the mtd method:

mtd -r write tplink.bin firmware

For the WR841N v14 follow the procedure above, but you must cut only the first 64k, so

dd if=orig.bin of=tplink.bin skip=129 bs=512

It is also possible to revert to the stock firmware using the method with tftp described in “TFTP install”. (you still need the firmware images without the boot part, unless you’re using v13, in which case refer to the instructions for TFTP flashing above).

OEM TP-Link firmware for the TL-WR841ND with the boot part removed or the original firmware if there wasn’t a boot part to revert to the original OEM firmware:

  • TL-WR841N(D) V1 2008613143645.zip

  • TL-WR841N(D) V3 TL-WR841ND-V3-stripped.zip

  • TL-WR841N(D) V5 201112613340616.zip

  • TL-WR841N(D) V7 TL-WR841ND-V7.zip

  • TL-WR841N(D) V8 TL-WR841ND-V8-stripped.zip

  • TL-WR841N(D) V9 TL-WR841ND-V9-stripped.zip

  • TL-WR841N(D) V10 TL-WR841ND-V10-stripped.zip

Как обновлять ПО

Существует ряд важных нюансов, знание которых до выполнения обновления очень вам поможет:

  • Настройки TP-LINK TL-WR841N будут сброшены к стандартным. Ничего трагического здесь нет, ведь устройство настраивается за считаные минуты. Специалисты рекомендуют копировать конфигурацию перед прошивкой. Для этого в интерфейсе прибора есть специальная опция.
  • Обновлять маршрутизатор можно только при кабельном соединении. Прошивать TP-LINK TL-WR841N по Wi-Fi категорически нельзя. Необходимо отключить опцию беспроводной сети на ПК и не включать прибор во время обновления.
  • Нужно отключить провод фирмы-провайдера от роутера на время прошивки. Это поможет избежать дополнительных трудностей во время обновления.
  • Целесообразно убедится в правильности выбранной микропрограммы для роутера. Воспользовавшись файлом для маршрутизатора другой модели, вы рискуете нарушить работоспособность своего роутера.

До того как начать поиски какой-то программы во всемирной паутине, важно понять, какая у вашего маршрутизатора аппаратная версия. Прочитать о версии TP-LINK TL-WR841N несложно, достаточно изучить наклейку, которая расположена на дне роутера

Как прошить роутер TP-Link

Обзор и настройка модема D-Link Dir-320 После того как пользователь получил данные о ревизии сетевого устройства, необходимо зайти на офсайт вендора и скачать правильную версию прошивки. Ссылка на сайт: https://www.tp-link.com.

  • Выбираем модель TP-Link. Для примера взята модель TL-WR740N, переходим в раздел «Поддержка».
  • Производитель предлагает выбрать версию ревизии.

Прошивки ПО для TP-Link-роутеров хранятся на сайте в зависимости от версий. Также прилагается подробная инструкция по обновлению в видеоформате и FAQ – наиболее часто встречающимся вопросам-ответам.

Скачиваем прошивку. Она представляет собой архив. Его необходимо распаковать на локальном диске, чтобы получить доступ к самой прошивке. Обычно программа представлена в виде файла с расширением .bin, но в старых моделях еще встречается файл .ras. Это устаревший вариант микрокода, не используемый в современных роутерах для обновления.

Далее переходим на веб-ресурс по управлению роутером, чтобы перепрошить его через веб-интерфейс. Прежде чем проводить какие-либо изменения в системе, сделайте резервную копию настроек. Поступаем следующим образом.

  1. Переходим в «Системные инструменты», потом – «Резервную копию» и «Восстановление».
  2. Выбираем пункт «Резервная копия».
  3. Указываем путь для сохранения и нажимаем ОК:

После создания копии переходим к разделу «Обновление встроенного ПО»:

  1. Нажимаем «Выберите файл», указываем скачанный дистрибутив:
  2. Нажимаем кнопку «Обновить». Процесс займет несколько минут.

После завершения процесса роутер автоматически перезагрузится. Его настройки сбросятся на заводские.

Существуют и другие способы, чтобы прошить модем TP-Link до актуальной версии.

Прошивка через USB-порт

Роутеры TP-Link, у которых в наличии есть USB-порт, способны получать актуальную версию ПО через флешку. Для этого необходимо загруженный дистрибутив скопировать на флеш-карту, предварительно отформатировав ее.

Следующий шаг – подключение ее через USB-порт к оборудованию. Далее повторяем шаги, описанные выше. То есть, заходим на веб-интерфейс оборудования в раздел с обновлением микропрограммы. Во время выбора файла указываем путь к USB-накопителю, на котором лежит дистрибутив.

Нажимаем «Обновить», ожидаем окончания процесса. Данный способ подходит, если сетевое устройство TP-Link находится на удаленном расстоянии от рабочей станции, и роутер напрямую не подключен ни к одному ПК.

Прошивка через мобильное приложение TP-Link Tether

Обновление прошивки на роутере TP-Link также производится через мобильное приложение. Ниже приведены ссылки для скачивания прошивок с магазина интернет-приложений:

  1. Android: https://play.google.com/store/apps/details?id=com.tplink.tether&hl=ru.
  2. iOS: https://itunes.apple.com/ru/app/tp-link-tether/id599496594?mt=8.

Стоит сказать, что у приложений есть список совместимости. Он находится в описании к ПО. Производитель официально заявляет, что список со временем будет пополняться.

Чтобы перепрошить роутер «ТП-Линк», надо скачать приложение, включить «вай-фай» на мобильном устройстве. Далее найти модель, микрокод которой надо обновить, подключаемся к ней через TP-Link Tether. Сетевое оборудование попросит пользователя ввести учетные данные.

После прохождения процедуры авторизации, попадаем в главное меню. В нем нужно посмотреть список подключенных устройств к сетевому оборудованию, установить параметры родительского контроля или изменить конфигурацию подключения к сети «Интернет».

К сожалению, обновить прошивку роутера через мобильное приложение теперь нельзя. На текущий момент функция недоступна.

Альтернативные версии прошивок

Кроме официальных версий прошивок для сетевого оборудования TP-Link, существуют и альтернативные сборки. Они созданы инициативными разработчиками для расширения функциональных возможностей заводских установок роутеров TP-Link для домашнего пользования, а также для точек доступа Auranet.

  • Программное обеспечение DD-WRT представляет собой альтернативный вариант микрокода, собранного на основе ядра OC семейства Linux. С его помощью любой роутер превращается в домашний медиасервер. Ссылка: ftp://ftp.dd-wrt.com/betas/.
  • Вторая, не менее известная прошивка, – OpenWrt. По сравнению с предыдущей представляет собой не готовый конфиг, а полноценный дистрибутив, собираемый пользователем самостоятельно под свои цели. Программа рассчитана на людей со знаниями в области сборки конфигураций из репозитория Linux-систем.

Способ обновления у них такой же, как и у официальных прошивок.

Как скачать прошивку для роутера TP-Link?

Что нужно знать перед тем, как скачать прошивку для TP-Link? Да все то же самое, что и у любого другого:

  1. Модель роутера
  2. Номер ревизии модели

Если с моделью все ясно — на роутер одной модификации не установится прошивка от другого, либо встанет криво. А вот номер ревизии нужно смотреть очень внимательно, потому что одни и те же модели разных лет выпусков могут отличаться.

Узнать ревизию, или как ее ещё называют, «аппаратную версию», надо на наклейке на корпусе роутера — она указывается рядом с наименованием самой модели и обозначается как VER.Х.Х, где Х.Х ее номер.

В нашем примере нужно искать прошивку на роутер TP-Link Archer C2 Ver.1.0, но для любой другой популярной модели, например TL-WR841N, WR740N или WR741ND, процесс происходит точно так же.

Прокручиваем страницу вниз и видим раздел «Загрузки»

В списке роутеров находим свою модель

На страничке загрузок для данной модели TP-Link выбираем в выпадающем списке аппаратную версию — мне нужна V1.

Прокручиваем вниз файлы документации и находим еще одно внутреннее меню, где нам нужен раздел «Встроенное ПО»

Тут мы видим несколько таблиц с описаниями последних обновлений — ищем самое свежее по дате (оно находится выше остальных). В описании видим, сколько различных исправлений было внесено в данную версию прошивки роутера TP-Link — еще один голос за то, чтобы делать обновление регулярно, чтобы поддерживать свой маршрутизатор в оптимальном состоянии.

Скачанный файл будет из себя представлять ZIP архив — его нужно распаковать, чтобы выудить из него файл прошивки TP-Link. Для этого кликаем по нему правой кнопкой мыши и выбираем «Извлечь все»

В новом окне ничего не меняем и жмем на кнопку «Извлечь»

Откроется новая папка, где будет лежать файл прошивки для роутера TP-Link — у него будет название что-то типа «Archer_C2v1_0.9.1_5.0_up_boot(170515)_2017-05-15_11.06.07», в зависимости от модели.

Ваше мнение — WiFi вреден?

Да
24.06%

Нет
75.94%

Проголосовало: 3317

Обновление

Как известно, все манипуляции по конфигурированию TP-LINK TL-WR841N выполняются в интерфейсе. В него легко попасть, достаточно в браузере вписать 192.168.0.1. Параметры для входа могут быть разными, если только вы меняли их при первоначальной настройке. Для нового оборудования подходят параметры admin/admin.

После этого вы увидите меню интерфейса. Прошивка ставится в пункте Frimware upgrade раздела System tools.

Осталось только указать место, где хранится ранее скачанный файл *.bin. Для этого кликните по клавише «Обзор» и пропишите путь. Затем выполните команду «Открыть».

Последний этап — начать обновление, нажав на Upgrade. На экране можно будет увидеть окно с надписью «Processing…». Процедура выполняется определённое время, в этот период не советуем отключать ПК или роутер. Приняв новую прошивку, изделие самостоятельно перезагрузится.

При следующем входе система попросит ввести login/pass, иначе попасть в меню не удастся. Вас и в данном случае выручат параметры admin/admin, поскольку устройство было сброшено к стандартным настройкам. Советуем сменить стандартные данные для входа, после чего загрузить ранее сохранённый файл конфигурации, это поможет полноценно работать с прибором. Теперь можно наслаждаться максимально эффективной конфигурацией TP-LINK TL-WR841N.

Обновление прошивки на Tp-link

Прежде всего, определим аппаратную версию устройства. При этом не имеет значения, какая у вас модель (TL-WR841N или TL-WR841ND). Проще всего сделать так: переверните роутер и внимательно изучите этикетку, наклеенную на корпусе. Место, где указана аппаратная версия, на рисунке обведено красным овалом.

Мы видим, что на наклейке написано Ver 9.2, следовательно, у нашего роутера аппаратная версия 9.2. На этом рисунке изображена устаревшая модель, так как в настоящее время у Tp-link разработана уже 12 аппаратная версия.

Теперь мы знаем, как определить номер версии нашего маршрутизатора. Это очень важная информация, которая обязательно потребуется при скачивании прошивки, потому что каждой версии устройства соответствует определенное программное обеспечение.

Перейдем к скачиванию файла для прошивки роутера

При обратите внимание: прошивка должна соответствовать вашей модели роутера и его аппаратной версии

Чтобы загрузить программное обеспечение с официального сайта Tp-link:

  • для модели TL-WR841N – перейдем по адресу: http://www.tp-linkru.com/download/TL-WR841N.html;
  • для модели TL-WR841ND – перейдем по адресу: http://www.tp-linkru.com/download/TL-WR841ND.html.

Когда нужная страница загрузится, выберем на ней версию, соответствующую информации, нанесенной на корпус устройства. Например, если в этикетке на корпусе было указано Ver 9.2, то выбираем V9.

После выбора аппаратной версии прокручиваем страницу, в самом низу находим вкладку Встроенное ПО (то есть прошивка).

Выбираем эту вкладку, в открывшемся окне появится список файлов. Первой по списку будет самая новая прошивка, поэтому нужно загружать именно ее. Для этого сохраним выбранный архивный файл на Рабочем столе нашего компьютера. Вы можете выбрать и другую папку для сохранения файла, главное, чтобы потом было легко его найти.

Откроем архивный файл и извлечем из него новую прошивку для нашего устройства.

Наконец мы скачали требуемое программное обеспечение, далее переходим к главному этапу – перепрошивке роутера.

Внимание! Делать прошивку при подключении через Wi-Fi нельзя. Прежде, чем вы начнете обновлять прошивку, нужно присоединить Tp-link TL-WR841N к компьютеру (ноутбуку) с помощью кабеля, который прилагается к роутеру

Запускаем любой браузер, который установлен у вас на компьютере. Вводим в адресной строке tplinklogin.net (Tplinklogin.net — адрес входа в личный кабинет роутеров TP-Link) или в старых прошивках 192.168.1.1 192.168.1.1 — вход в настройки роутера, логин и пароль Admin и ждем, пока загрузится страница. Затем вас попросят ввести имя пользователя (admin) и пароль (admin)

В окне настроек открываем вкладку System Tools, из списка ниже выбираем Firmware Upgrade. После этого нажимаем в окне на расположенную сверху кнопку Выберите файл. Когда откроется Проводник, найдем и выберем в окне наш файл с новой прошивкой.

Для перепрошивки роутера до более новой версии в следующем окне нажмем Upgrade. На экране это будет выглядеть примерно так.

Подождем, пока прошивка будет обновляться.

После завершения перепрошивки, необходимо перезагрузить систему. После перезагрузки можно будет работать с роутером.

Возврат на программное обеспечение производителя

1. Скачайте оригинальный образ прошивки с сайта TP-Link(у версий 1 и 1.5 абсолютно идентичные последние прошивки), для версии 3.

2. Извлеките файл из архива и посмотрите содержит ли он в своем названии слово boot,

  • Если не содержит, то можете спокойно им прошивать.
  • Если содержит, то нужно немного отредактировать перед прошивкой:

Данный способ подходит для моделей V1, V3, V5, V7, V8 и V9; так как бутлоадер у них одного размера.
Для примера возьмем файл со словом “boot” в названии wr841nv9_en_3_14_4_up_boot(131129).bin
Вырезаем первые 0x20200 (это 131,584 = 257*512) байт прошивки:

dd if=wr841nv9_en_3_14_4_up_boot(131129).bin of=tplink.bin skip=257 bs=512

Получаете файл tplink.bin, данную команду можно провести на компьютере с linux/unix или на самом роутере(предварительно закачав его туда с помощью web сервера или по протоколу scp)

Так же вы можете просто скачать уже модифицированные файлы без boot блока

  • TL-WR841N(D) V1 2008613143645.zip

  • TL-WR842N(D) V3 TL-WR841ND-V3-stripped.zip

  • TL-WR841N(D) V5 201112613340616.zip

  • TL-WR841N(D) V7 TL-WR841N_WR841ND_v7_120201.zip

  • TL-WR842N(D) V8 TL-WR841ND-V8-stripped.zip

  • TL-WR842N(D) V9 TL-WR841ND-V9-stripped.zip

3. Полученный файл переименуйте во что-то типа tplink.bin и можете прошить через web интерфейс, если же возможности нет, то можно через консоль, используйте протокол SCP (для windows winscp), если вы на линуксе то и сами все знаете, так же можно воспользоваться веб-сервером в локальной сети):

Скачайте файл в tmp папку роутера с помощью scp или wget, если у вас есть web сервер (для примера, 192.168.1.110 — адрес web сервера)

root@OpenWrt:~# cd /tmp
root@OpenWrt:/tmp# wget http://192.168.1.110/tplink.bin

Прошейте

root@OpenWrt:/tmp# mtd -r write ./tplink.bin firmware

Вы так же можете попробовать уже описанный способ установки по tftp(boot часть опять же придется вырезать)

См. также Back to original firmware

Вход в настройки

После того, как выбранный тип соединения установлен, заходят в настройки роутера Tp-Link Tl Wr841n.

В адресной строке браузера вбивают адрес http://192.168.1.1 (написан на наклейке) или альтернативный http://tplinklogin.net. Любой из вариантов должен предложить ввести логин и пароль.

Вход, как на скриншоте выше, или похожее окно в тонах роутера. Эти данные от версии к версии не меняются — admin в оба поля. Именно с маленькой буквы и без дополнительных символов. Если пользователь переворачивал роутер перед тем, как подключать, мог видеть их и на наклейке. Подтвердив данные нажатием ввода на клавиатуре, входят в web-интерфейс устройства.

Если роутер ранее не настраивался, на экране появляется мастер быстрой настройки, который любезно сообщает, что если он пользователю не нужен, тот может нажать «Выход».

Меняем пароль

Воспользовавшись предложением, закрывают мастера и идут в «Системные инструменты», где на странице «Пароль» меняют данные для входа в web-интерфейс.

Прочитав грозное предупреждение, написанное алым шрифтом, придумывают новое имя пользователя и пароль. Последний набирают дважды для контроля. Чтобы обновление вступило в силу, чуть выше вводят старые данные «admin/admin». Маршрутизатор перезагрузится. Дальнейшая настройка Tp-Link Tl Wr841n потребует правильного ввода уже новых данных.

Debricking

v7

  1. Disconnect the router from the internet, connect it with a PC via RJ45 cable and perform a 30/30/30 restart
  2. Change the IP on the PC to 192.168.1.2. Subnet mask must be 255.255.255.0. Restart the router by unplugging the power cable.
  3. Perform a failsafe boot and quickly use

    telnet 192.168.1.1

If this didn’t work, check the IP address on the PC or if you were too slow to connect during the failsafe mode. Still not working? Read this!

In telnet, do the following things one after another:

Define a passwordpasswd

enter

yourpassword

enter

againyourpassword

enter

Kill the broken OWrt firmwaremtd -r erase rootfs_data

enter

firstboot

enter

reboot -f

After rebooting, log in again just to check if the router is accessible. If you can’t, start again at the beginning.

Now change the network settings on the PC back to “Acquire IP address automatically” and connect the router with the internet. Do a manual reboot by simply turning it off and back on again. The PC should now get an IP address by DHCP. If this is the case, you successfully reset the router. If not, repeat from the beginning or do this if you like.

Basically the router now works like after the initial flash to OWrt. Now you have to configure the internet connection and probably you want to install LUCI. After that, open your browser, connect to 192.168.1.1 and log in with the data you entered via telnet.

Поиск прошивки

Качать ПО для роутера следует исключительно с проверенных ресурсов глобальной сети. Для вашего прибора подойдёт сайт фирмы TP-Link. Попав на этот ресурс, введите в поиске модель своего роутера. Результатом должна стать ссылка на необходимую модель. Далее, во вкладке «Загрузки» рекомендуем выбрать «Встроенное ПО» (пункт находится в «ПО») и кликнуть по своей аппаратной версии.

Важно понимать, что установка с сайта фирмы-разработчика обеспечивает правильную работу роутера. Вы не потеряете возможность гарантийного ремонта TP-LINK TL-WR841N, если будете пользоваться таким методом

Гарантия с устройства снимается во всех остальных случаях. Такое бывает при эксплуатации сторонних утилит (DD-WRT, к примеру).

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector